The ingestion and synchronization issue affecting Wiz Data Findings in ArmorCode has been resolved. The incident was caused by an unannounced change in Wiz’s data model/response schema for the Data Findings asset type.
Our engineering team has updated the integration to align with the new Wiz schema, and all findings are now ingesting and synchronizing as expected.
The impact was limited to the Data Findings asset type. All other Wiz asset types continued functioning normally throughout the incident. Less than 1% of total open findings were affected.
We appreciate your patience while we worked to restore full functionality.
Incident Resolved Time : September 15, 2025, 12:15 UTC
Posted Sep 16, 2025 - 10:43 UTC
Update
Current Status : Our team is developing a fix, which is expected to be rolled out early next week.
Issue : A recent change by Wiz to the unique identifier in their Data Findings API has impacted ArmorCode's deduplication logic, causing some findings to become misaligned.
Planned Resolution : We will re-ingest all findings to apply the correct deduplication logic and perform a data migration to ensure finding counts are accurate and consistent between ArmorCode and Wiz.
Posted Sep 13, 2025 - 06:46 UTC
Identified
Wiz has implemented an unannounced changes to the data model/response schema for their Data Findings asset type. As a result, the ingestion and synchronization of Data Findings from Wiz into ArmorCode may be delayed or out of sync.
This incident is only isolated to the Data Findings asset type. All other asset types from the Wiz integration are ingesting and synchronizing as expected. Less than 1% of total open findings are affected.
Our engineering team is actively working to update our integration to align with these new schema changes.
Incident Start Time: September 8, 2025, 16:09 UTC
Posted Sep 11, 2025 - 14:41 UTC
This incident affected: ArmorCode US (US : Data Processing) and ArmorCode EU (EU : Data Processing).