Elevated Error Rate in Prisma Cloud RedLock Integration

Incident Report for ArmorCode

Resolved

The Prisma Cloud RedLock team has resolved the issue, and we are no longer observing API errors for failed integrations. Scans and integration flows are now functioning as expected.

Thank you for your patience and understanding while we worked with the RedLock team to address this incident.

Incident Resolved Time : August 8, 2025, 16:30 UTC
Posted Aug 09, 2025 - 12:30 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 08, 2025 - 11:47 UTC

Identified

We are currently experiencing an elevated error rate with the Prisma Cloud RedLock integration. Many integration attempts are failing with the error: "Failed to fetch RedLock alerts."

Our engineering team is actively investigating the issue in collaboration with the RedLock team. Initial findings suggest the problem originates on the RedLock side.

We will provide further updates as soon as more information becomes available.

Incident Start Time: August 8, 2025, 08:55 UTC
Posted Aug 08, 2025 - 11:46 UTC
This incident affected: ArmorCode US (US : Portal (app.armorcode.com)) and ArmorCode EU (EU : Portal (eu.armorcode.com)).